********************************************************************* This is the Internet Gateway for Sprint. Sprint customers should contact Sprint Messaging Support for assistance; others should contact their service provider. ********************************************************************* [last updated 11/11/95 CHL] This file is divided into several sections: 1. Introduction 2. Addressing Sprint X.400 Users 3. Mime/X.400 Translation 4. Frequently Asked Questions (FAQ) 5. Getting More Information on Sprint Products and Services 6. Appendix 1. INTRODUCTION The Sprint X.400/Internet Gateway links thousands of government agencies, businesses and individual users of the Sprint X.400 mail network with the Internet. At the gateway, Internet messages in RFC-822 format are first converted to X.400 format and are then forwarded to the appropriate X.400 mail system. A similar conversion takes place in the X.400 to RFC-822 direction. This help file is primarily designed to assist Internet users who are trying to reach Sprint X.400 customers. X.400 users should consult the Internet help file on their local system for more information about sending mail to the Internet. 2. ADDRESSING SPRINT X.400 USERS The simplest way to learn the E-mail address of a Sprint X.400 user is to call the user, or have the user send mail to your Internet address. For security and privacy reasons, Sprint as a policy does not release E-mail addresses. Please also note that Sprint does not maintain a global directory of X.400 E-mail addresses. X.400 addresses contain several parts: C = country ADMD = Administrative Domain PRMD = Private Mail Domain OU = Orginizational Unit O = Organization G = Given Name S = Surname I = Initial PN = Personal Name DD.ID = Domain Dependent Identifier To address a Sprint X.400 user from the Internet, you will need to use all, or some of the above address parts. Here is an example address for a user who has a mail account on a private mail system of the company World Wide Widgets: "/G=Joe/S=Smith/O=Marketing/PRMD=World Wide Widgets"@sprint.com If any X.400 address information is left out of an address (i.e. the ADMD was not specified in the above message), the gateway will default to /ADMD=telemail/C=us. Most X.400 addresses will look much simpler to Internet users. The gateway, following rules in RFC-1327, will automatically simplify many addresses. For example, "/G=Joe/S=Smith/O=Marketing/PRMD=Acme/ADMD=telemail/C=us/" will appear as Joe.Smith@Marketing.Acme.sprint.com Please contact your local system administrator, or consult RFC-1327 for more information about these simplified mappings between RRFC-822 and X.400. Sprintmail X.400 users mail also send mail to the below address to learn the Internet version of their X.400 address: X.400 : (S:echo, O:gateway, P:internet, A:telemail, C:us) RFC-822: echo@gateway.sprint.com 3. MIME/X.400 The gateway now supports MIME to X.400(84) message transfers. Internet users can send voice, video, binary files and many other file attachments to X.400 users using MIME (RFC-1341) encodings. At the moment, all non-text Internet body-parts will be received as binary attachments by X.400 users. Please contact your local system administrator, or consult RFC-1495 for more information about Mime/X.400 message transfers. 4. FAQ (1) Question: I have a friend named Bob who works at Frank's Fast Food in Kansas City. Do you know what his E-mail address is? Answer: No. Sprint does not maintain a directory of E-mail addresses. If your friend is a Sprint X.400 customer, he should send mail to echo@gateway.sprint.com, or call Sprint Global Technical Support to learn the Internet version of his E-mail address. In addition, please note that Sprint as a policy does not release E-mail addresses for reasons of privacy and security. (2) Question: I received an error message when I tried to mail to my friend Donna at Acme, Inc. What am I doing wrong? Here is what the header of the error message I got back looked like: > Date: Sat, 12 Nov 1994 00:25:17 -0500 > From: postmaster@gateway.sprint.com > To: joe.user@company.com > Subject: Delivery Report (failure) for Donna@acme.sprint.com Answer: If you look further down in the error message, you will see that the error message, or delivery report (DR), was generated by the private mail system at Acme, Inc: > DR generated in /PRMD=ACME/ADMD=TELEMAIL/C=US/ You will have to speak directly to your friend, or the system administrators at Amce to resolve any addressing problems. In the case of this message, Sprint is only acting as a transit X.400 network for your mail. (3) Question: I have a friend in Russia who says his X.400 address is: (C:USSR,A:SOVCUST,O:BLEE,UN:FRED) How do I send mail to my friend from the Internet? Answer: This X.400 address maps to: "/S=fred/O=blee/A=sovcust/C=su"@sprint.com or, a bit simpler: "/S=fred/O=blee"@sovcust.sprint.com Note that the country name, USSR, becomes SU in the Internet version of the X.400 address. All X.400 country names must be exactly TWO letters when included in an Internet version of the address (See the Appendix for a list of Country Codes). Again, please note that the easiest way to learn the address your friend is to have him/her send mail to your Internet address. (4) Question: Our Internet site is using really old mail software that does not seem to treat the parenthesises and spaces in my friend's X.400 address correctly. I have been asking my system administrator to install software that does not have these bugs, but until he updates the software is there any other way I can address my friend? His address is: "/DD.WPMAIL=APFS2(JOE SMITH)"@widgets.sprint.com Answer: The real solution is for your system administrator to update your software. Spaces, quotes, and parantheses are legal RFC-822 characters. You will have difficulties sending mail to Sprint customers, and thousands of other Internet hosts and gateway until you correct your software. As a temporary service, the Sprint Internet gateway software automatically will perform the following translations: '{' as '(' '}' as ')' '_' as a space So, you could address your friend as: "/DD.WPMAIL=APFS2{JOE_SMITH}"@widgets.sprint.com 5. Getting More Information on Sprint Products and Services Connect to the Sprint World Wide Web page at: http://www.sprintlink.net Information about Sprintlink Internet services is also available by calling 1-800-817-SPLK, or sending E-mail to sales@sprintlink.net Information about SprintNet X.25 services is also available by calling 1-800-877-5045. Other Sprint Telephone Numbers: SPRINTNET (PDN) INFORMATION OR TROUBLE = 800-877-5045 SPRINT VOICE INFORMATION (SALES) = 800-877-2000 SPRINT LONG DISTANCE = 800-877-2000 SPRINT RESIDENTIAL = 800-877-4646 SPRINT COMMERCIAL = 800-877-5045 6. Appendix ISO Country Codes AFGHANISTAN AF ALBANIA AL ALGERIA DZ AMERICAN SAMOA AS ANDORRA AD ANGOLA AO ANGUILLA AI ANTARCTICA AQ ANTIGUA AND BARBUDA AG ARGENTINA AR ARUBA AW AUSTRALIA AU AUSTRIA AT BAHAMAS BS BAHRAIN BH BANGLADESH BD BARBADOS BB BELGIUM BE BELIZE BZ BENIN BJ BERMUDA BM BHUTAN BT BOLIVIA BO BOTSWANA BW BOUVET ISLAND BV BRAZIL BR BRITISH INDIAN OCEAN TERRITORY IO BRUNEI DARUSSALAM BN BULGARIA BG BURKINA FASO BF BURUNDI BI BYELORUSSIAN SSR BY CAMBODIA KH CAMEROON CM CANADA CA CAPE VERDE CV CAYMAN ISLANDS KY CENTRAL AFRICAN REPUBLIC CF CHAD TD CHILE CL CHINA CN CHRISTMAS ISLAND CX COCOS (KEELING) ISLANDS CC COLOMBIA CO COMOROS KM CONGO CG COOK ISLANDS CK COSTA RICA CR COTE D'IVOIRE CI CUBA CU CYPRUS CY CZECHOSLOVAKIA CS DENMARK DK DJIBOUTI DJ DOMINICA DM DOMINICAN REPUBLIC DO EAST TIMOR TP ECUADOR EC EGYPT EG EL SALVADOR SV EQUATORIAL GUINEA GQ ETHIOPIA ET FALKLAND ISLANDS (MALVINAS) FK FAROE ISLANDS FO FIJI FJ FINLAND FI FRANCE FR FRENCH GUIANA GF FRENCH POLYNESIA PF FRENCH SOUTHERN TERRITORIES TF GABON GA GAMBIA GM GERMANY DE GHANA GH GIBRALTAR GI GREECE GR GREENLAND GL GRENADA GD GUADELOUPE GP GUAM GU GUATEMALA GT GUINEA GN GUINEA-BISSAU GW GUYANA GY HAITI HT HEARD AND MC DONALD ISLANDS HM HONDURAS HN HONG KONG HK HUNGARY HU ICELAND IS INDIA IN INDONESIA ID IRAN (ISLAMIC REPUBLIC OF) IR IRAQ IQ IRELAND IE ISRAEL IL ITALY IT JAMAICA JM JAPAN JP JORDAN JO KENYA KE KIRIBATI KI KOREA, DEMOCRATIC PEOPLE'S REPUBLIC OF KP KOREA, REPUBLIC OF KR KUWAIT KW LAO PEOPLE'S DEMOCRATIC REPUBLIC LA LEBANON LB LESOTHO LS LIBERIA LR LIBYAN ARAB JAMAHIRIYA LY LIECHTENSTEIN LI LUXEMBOURG LU MACAU MO MADAGASCAR MG MALAWI MW MALAYSIA MY MALDIVES MV MALI ML MALTA MT MARSHALL ISLANDS MH MARTINIQUE MQ MAURITANIA MR MAURITIUS MU MEXICO MX MICRONESIA FM MONACO MC MONGOLIA MN MONTSERRAT MS MOROCCO MA MOZAMBIQUE MZ MYANMAR MM NAMIBIA NA NAURU NR NEPAL NP NETHERLANDS NL NETHERLANDS ANTILLES AN NEUTRAL ZONE NT NEW CALEDONIA NC NEW ZEALAND NZ NICARAGUA NI NIGER NE NIGERIA NG NIUE NU NORFOLK ISLAND NF NORTHERN MARIANA ISLANDS MP NORWAY NO OMAN OM PAKISTAN PK PALAU PW PANAMA PA PAPUA NEW GUINEA PG PARAGUAY PY PERU PE PHILIPPINES PH PITCAIRN PN POLAND PL PORTUGAL PT PUERTO RICO PR QATAR QA REUNION RE ROMANIA RO RWANDA RW ST. HELENA SH SAINT KITTS AND NEVIS KN SAINT LUCIA LC ST. PIERRE AND MIQUELON PM SAINT VINCENT AND THE GRENADINES VC SAMOA WS SAN MARINO SM SAO TOME AND PRINCIPE ST SAUDI ARABIA SA SENEGAL SN SEYCHELLES SC SIERRA LEONE SL SINGAPORE SG SOLOMON ISLANDS SB SOMALIA SO SOUTH AFRICA ZA SPAIN ES SRI LANKA LK SUDAN SD SURINAME SR SVALBARD AND JAN MAYEN ISLANDS SJ SWAZILAND SZ SWEDEN SE SWITZERLAND CH SYRIAN ARAB REPUBLIC SY TAIWAN, PROVINCE OF CHINA TW TANZANIA, UNITED REPUBLIC OF TZ THAILAND TH TOGO TG TOKELAU TK TONGA TO TRINIDAD AND TOBAGO TT TUNISIA TN TURKEY TR TURKS AND CAICOS ISLANDS TC TUVALU TV UGANDA UG UKRAINIAN SSR UA UNITED ARAB EMIRATES AE UNITED KINGDOM GB UNITED STATES US UNITED STATES MINOR OUTLYING ISLANDS UM URUGUAY UY USSR SU VANUATU VU VATICAN CITY STATE (HOLY SEE) VA VENEZUELA VE VIET NAM VN VIRGIN ISLANDS (BRITISH) VG VIRGIN ISLANDS (U.S.) VI WALLIS AND FUTUNA ISLANDS WF WESTERN SAHARA EH YEMEN, REPUBLIC OF YE YUGOSLAVIA YU ZAIRE ZR ZAMBIA ZM ZIMBABWE ZW Please send suggestions and comments for improving this help file to: RFC-822: postmaster@gateway.sprint.com X.400 : (S:postmaster, O:gateway, A:telemail, P:internet, C:us)